CVE-2021-31999GHSA-PVXJ-25M6-7VQRGO-2024-2778
Rancher: Privilege escalation vulnerability via malicious Connection header
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.5.9, 2.4.16
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A Reliance on Untrusted Inputs in a Security Decision vulnerability in Rancher allows users in the cluster to act as others users in the cluster by forging the "Impersonate-User" or "Impersonate-Group" headers. This issue affects: Rancher versions prior to 2.5.9. Rancher versions prior to 2.4.16.
Timeline
- CVE published
- Record last updated
Affected versions
- Rancher Rancher
From Rancher · fixed in 2.5.9
- Rancher SUSE Linux Enterprise Server 15
From Rancher · fixed in 2.4.16
- github.com/rancher/rancherGo
From 2.0.0 · fixed in 2.4.16
- github.com/rancher/rancherGo
From 2.5.0 · fixed in 2.5.9
- github.com/rancher/rancherGo
From 2.0.0+incompatible