Skip to main content
← All vulnerabilities
CVE-2021-31407GHSA-25XC-JWFQ-39JW

Server classes and resources exposure in OSGi applications using Vaadin 12-14 and 19

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.8, 6.0.1
None on Exploit-DB, Metasploit or GitHub

Summary

Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Vaadin Vaadin

    From 12.0.0

  • Vaadin flow-server

    From 1.2.0

  • com.vaadin:flow-serverMaven

    From 1.2.0 · fixed in 2.4.8

  • com.vaadin:flow-serverMaven

    From 6.0.0 · fixed in 6.0.1

References 4

vaadin.com

GitHub · vaadin/osgi

GitHub · vaadin/flow