Skip to main content
← All vulnerabilities
CVE-2021-3129GHSA-4QWP-7C67-JMCC

Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated remote attackers to execute arbitrary code because of i

Published
Last modified
published
Listed in CISA KEV
Fix
Fixed in 2.5.2, 2.4.2, 1.16.14, 1.6.15
None on Exploit-DB, Metasploit or GitHub

Summary

Ignition, the error-page debugging component used in Laravel and some other PHP products, is affected. An unauthenticated remote attacker could exploit it to run arbitrary code on servers where debug mode is enabled.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated remote attackers to execute arbitrary code because of insecure usage of file_get_contents() and file_put_contents(). This is exploitable on sites using debug mode with Laravel before 8.4.2.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • facade/ignitionPackagist

    From 2.5.0 · fixed in 2.5.2

  • facade/ignitionPackagist

    From 2.0.0 · fixed in 2.4.2

  • facade/ignitionPackagist

    From 1.7.0 · fixed in 1.16.14

  • facade/ignitionPackagist

    fixed in 1.6.15

References 4

ambionics.io

GitHub · facade/ignition

packetstormsecurity.com