Skip to main content
← All vulnerabilities
CVE-2021-3114GO-2021-0235BIT-GOLANG-2021-3114

In Go before 1.14.14 and 1.15.x before 1.15.7, crypto/elliptic/p224.go can generate incorrect outputs, related to an underflow of the lowest

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.14.14, 1.15.7
None on Exploit-DB, Metasploit or GitHub

Summary

In Go before 1.14.14 and 1.15.x before 1.15.7, crypto/elliptic/p224.go can generate incorrect outputs, related to an underflow of the lowest limb during the final complete reduction in the P-224 field.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • stdlibGo

    fixed in 1.14.14; From 1.15.0-0 · fixed in 1.15.7

References 8

groups.google.com

GitHub · golang/go

lists.fedoraproject.org

debian.org

security.netapp.com

lists.debian.org

security.gentoo.org