CVE-2021-30638GHSA-GHM8-MMX7-XVG2
An Information Disclosure due to insufficient input validation exists in Apache Tapestry 5.4.0 and later
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in Apache Tapestry 5.6.4, Apache Tapestry 5.7.2, 5.6.4, 5.7.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Information Exposure vulnerability in context asset handling of Apache Tapestry allows an attacker to download files inside WEB-INF if using a specially-constructed URL. This was caused by an incomplete fix for CVE-2020-13953. This issue affects Apache Tapestry Apache Tapestry 5.4.0 version to Apache Tapestry 5.6.3; Apache Tapestry 5.7.0 version and Apache Tapestry 5.7.1.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Tapestry
fixed in Apache Tapestry 5.6.4; fixed in Apache Tapestry 5.7.2
- org.apache.tapestry:tapestry-coreMaven
From 5.4.0 · fixed in 5.6.4
- org.apache.tapestry:tapestry-coreMaven
From 5.7.0 · fixed in 5.7.2