CVE-2021-3057
GlobalProtect App: Buffer Overflow Vulnerability When Connecting to Portal or Gateway
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.1.9, 5.2.8, 5.3.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A stack-based buffer overflow vulnerability exists in the Palo Alto Networks GlobalProtect app that enables a man-in-the-middle attacker to disrupt system processes and potentially execute arbitrary code with SYSTEM privileges. This issue impacts: GlobalProtect app 5.1 versions earlier than GlobalProtect app 5.1.9 on Windows; GlobalProtect app 5.2 versions earlier than GlobalProtect app 5.2.8 on Windows; GlobalProtect app 5.2 versions earlier than GlobalProtect app 5.2.8 on the Universal Windows Platform; GlobalProtect app 5.3 versions earlier than GlobalProtect app 5.3.1 on Linux.
Timeline
- CVE published
- Record last updated
Affected versions
- Palo Alto Networks GlobalProtect App
From 5.1 · fixed in 5.1.9; From 5.2 · fixed in 5.2.8
- Palo Alto Networks GlobalProtect App
From 5.3 · fixed in 5.3.1
- Palo Alto Networks GlobalProtect App
From 5.2 · fixed in 5.2.8