CVE-2021-30458GHSA-5PQX-77VF-85RW
An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.12.2, 0.11.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- wikimedia/parsoidPackagist
From 0.12 · fixed in 0.12.2
- wikimedia/parsoidPackagist
fixed in 0.11.1