Skip to main content
← All vulnerabilities
CVE-2021-30130GHSA-VF4W-FG7R-5V94

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.7, 2.0.31
None on Exploit-DB, Metasploit or GitHub

Summary

phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • phpseclib/phpseclibPackagist

    From 3.0.0 · fixed in 3.0.7

  • phpseclib/phpseclibPackagist

    fixed in 2.0.31

References 5

GitHub · phpseclib/phpseclib

lists.debian.org