CVE-2021-28813
Insufficiently Protected Credentials Vulnerability in QSW-M2116P-2T2S and QuNetSwitch
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.0.6 build 210713, 1.0.6.1509, 1.0.6.1519
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A vulnerability involving insecure storage of sensitive information has been reported to affect QSW-M2116P-2T2S and QNAP switches running QuNetSwitch. If exploited, this vulnerability allows remote attackers to read sensitive information by accessing the unrestricted storage mechanism.We have already fixed this vulnerability in the following versions: QSW-M2116P-2T2S 1.0.6 build 210713 and later QGD-1600P: QuNetSwitch 1.0.6.1509 and later QGD-1602P: QuNetSwitch 1.0.6.1509 and later QGD-3014PT: QuNetSwitch 1.0.6.1519 and later
Timeline
- CVE published
- Record last updated
Affected versions
- QNAP Systems Inc. QSW-M2116P-2T2S
fixed in 1.0.6 build 210713
- QNAP Systems Inc. QuNetSwitch
fixed in 1.0.6.1509
- QNAP Systems Inc. QuNetSwitch
fixed in 1.0.6.1509
- QNAP Systems Inc. QuNetSwitch
fixed in 1.0.6.1519