CVE-2021-28807
Post-Authentication Reflected XSS Vulnerability in Q'center
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in v1.12.1012, v1.10.1004
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A post-authentication reflected XSS vulnerability has been reported to affect QNAP NAS running Q’center. If exploited, this vulnerability allows remote attackers to inject malicious code. QNAP have already fixed this vulnerability in the following versions of Q’center: QTS 4.5.3: Q’center v1.12.1012 and later QTS 4.3.6: Q’center v1.10.1004 and later QTS 4.3.3: Q’center v1.10.1004 and later QuTS hero h4.5.2: Q’center v1.12.1012 and later QuTScloud c4.5.4: Q’center v1.12.1012 and later
Timeline
- CVE published
- Record last updated
Affected versions
- QNAP Systems Inc. Q’center
fixed in v1.12.1012
- QNAP Systems Inc. Q’center
fixed in v1.10.1004
- QNAP Systems Inc. Q’center
fixed in v1.10.1004
- QNAP Systems Inc. Q’center
fixed in v1.12.1012
- QNAP Systems Inc. Q’center
fixed in v1.12.1012