Skip to main content
← All vulnerabilities
CVE-2021-28585GHSA-C38M-9668-6J2WBIT-MAGENTO-2021-28585

Magento Commerce improper input validation in customer customer webapi

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.2-p1, 2.3.7
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper input validation vulnerability in the New customer WebAPI.Successful exploitation could allow an attacker to send unsolicited spam e-mails.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.2; through 2.3.6-p1; through 2.4.1-p1

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.2-p1

  • magento/community-editionPackagist

    fixed in 2.3.7

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com