Skip to main content
← All vulnerabilities
CVE-2021-28583GHSA-7GH6-F4JH-3CRQBIT-MAGENTO-2021-28583

Magento Commerce insecure storage of sensitive documentation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.2-p1, 2.3.7
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a Violation of Secure Design Principles vulnerability in RMA PDF filename formats. Successful exploitation could allow an attacker to get unauthorized access to restricted resources.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.2; through 2.3.6-p1; through 2.4.1-p1

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.2-p1

  • magento/community-editionPackagist

    fixed in 2.3.7

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com