CVE-2021-28567GHSA-CC3W-R3W8-HFH7BIT-MAGENTO-2021-28567
Magento Commerce improper authorization allows an authenticated user to perform certain functions without permission
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.4.2-p1, 2.3.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation.
Timeline
- CVE published
- Record last updated
Affected versions
- Adobe Magento Commerce
through 2.4.2; through 2.3.6-p1; through 2.4.1-p1
- magento/community-editionPackagist
From 2.4.0 · fixed in 2.4.2-p1
- magento/community-editionPackagist
fixed in 2.3.7
- magento/project-community-editionPackagist
through 2.0.2