Skip to main content
← All vulnerabilities
CVE-2021-28563GHSA-Q9XX-4689-GVV5BIT-MAGENTO-2021-28563

Magento Commerce improper Authorization via the 'Create Customer' endpoint

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.2-p1, 2.3.7
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper Authorization vulnerability via the 'Create Customer' endpoint. Successful exploitation could lead to unauthorized modification of customer data by an unauthenticated attacker. Access to the admin console is required for successful exploitation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.2; through 2.3.6-p1; through 2.4.1-p1

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.2-p1

  • magento/community-editionPackagist

    fixed in 2.3.7

References 1

helpx.adobe.com