Skip to main content
← All vulnerabilities
CVE-2021-28556GHSA-39CH-RG26-GMQ5BIT-MAGENTO-2021-28556

Magento Commerce DOM-based cross-site scripting (XSS) could lead to arbitrary javascript execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.2-p1, 2.3.7
None on Exploit-DB, Metasploit or GitHub

Summary

Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Adobe Magento Commerce

    through 2.4.2; through 2.3.6-p1; through 2.4.1-p1

  • magento/community-editionPackagist

    From 2.4.0 · fixed in 2.4.2-p1

  • magento/community-editionPackagist

    fixed in 2.3.7

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com