Skip to main content
← All vulnerabilities
CVE-2021-25979GHSA-9J9M-8WJC-FF96

Apostrophe - Insufficient Session Expiration

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.4.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Apostrophe CMS versions prior to 3.3.1 did not invalidate existing login sessions when disabling a user account or changing the password, creating a situation in which a device compromised by a third party could not be locked out by those means. As a mitigation for older releases the user account in question can be archived (3.x) or moved to the trash (2.x and earlier) which does disable the existing session.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apostrophe Apostrophe

    through 3.3.1; From 2.63.0

  • apostrophenpm

    From 2.63.0 · fixed in 3.4.0

References 1

GitHub · apostrophecms/apostrophe