Skip to main content
← All vulnerabilities
CVE-2021-25978GHSA-4R9C-JGHC-CX5M

Apostrophe - XSS

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.4.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Apostrophe CMS versions between 2.63.0 to 3.3.1 are vulnerable to Stored XSS where an editor uploads an SVG file that contains malicious JavaScript onto the Images module, which triggers XSS once viewed.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apostrophe Apostrophe

    through 3.3.1; From 2.63.0

  • apostrophenpm

    From 2.63.0 · fixed in 3.4.0

References 1

GitHub · apostrophecms/apostrophe