CVE-2021-25959GHSA-RWH9-8XX8-4WFM
OpenCRX - Reflected Cross-Site Scripting in Password Reset Functionality
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.2.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
Timeline
- CVE published
- Record last updated
Affected versions
- org.opencrx opencrx-core-config
From 4.0.0
- org.opencrx:opencrx-coreMaven
From 4.0.0 · fixed in 5.2.0
- org.opencrx:opencrx-core-modelsMaven
From 4.0.0 · fixed in 5.2.0
- org.opencrx:opencrx-core-configMaven
From 4.0.0 · fixed in 5.2.0
- org.opencrx:opencrx-clientMaven
From 4.0.0 · fixed in 5.2.0
- org.opencrx:opencrx-gradleMaven
From 4.0.0 · fixed in 5.2.0