CVE-2021-25642GHSA-RR2M-GFFV-MGRJ
Apache Hadoop YARN remote code execution in ZKConfigurationStore of capacity scheduler
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.10.2, 3.2.4, 3.3.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Hadoop
Version range not reported
- org.apache.hadoop:hadoop-yarn-serverMaven
fixed in 2.10.2
- org.apache.hadoop:hadoop-yarn-serverMaven
From 3.0.0 · fixed in 3.2.4
- org.apache.hadoop:hadoop-yarn-serverMaven
From 3.3.0 · fixed in 3.3.4