CVE-2021-25318GO-2024-2768GHSA-F9XF-JQ4J-VQW4
rancher: API group not properly specified when creating Kubernetes RBAC resources
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.5.9, 2.4.16
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A Incorrect Permission Assignment for Critical Resource vulnerability in Rancher allows users in the cluster to modify resources they should not have access to. This issue affects: Rancher versions prior to 2.5.9 ; Rancher versions prior to 2.4.16.
Timeline
- CVE published
- Record last updated
Affected versions
- Rancher Rancher
From Rancher · fixed in 2.5.9
- Rancher Rancher
From Rancher · fixed in 2.4.16
- github.com/rancher/rancherGo
From 2.0.0+incompatible
- github.com/rancher/rancherGo
From 2.0.0 · fixed in 2.4.16
- github.com/rancher/rancherGo
From 2.5.0 · fixed in 2.5.9